The angular cli requires a minimum node.js version of either v14.20, v16.13 or v18.10 – Dépannage

Comment résoudre l’erreur The angular cli requires a minimum node.js version of either v14.20, v16.13 or v18.10

Une mise à jour plus récente du post existe sur troubleshooter.tedidev.com

Vous êtes en train de créer un projet angular sous un linux de type debian pour la première fois et vous trouvez cet erreur “The angular cli requires a minimum node.js version of either v14.20, v16.13 or v18.10 “. Que faire ?

Dans ce genre de situation on comprend assez rapidement qu’il suffit de mettre à jour notre node js.

Le problème est que parfois on rencontre des imprévus. C’est ce qui nous est arrivé avec notre ubuntu 16.04 LTS et pour le régler, nous vous proposons notre solution.

Pour profiter de plus de contenu en exclusivité, abonez vous à notre newsletter.

The angular cli requires a minimum node.js version of either v14.20, v16.13 or v18.10

Pour résoudre de tel problème il suffit de faire la mise à jour de Nodejs, pour celà il ya deux moyens :

  • La mise à jour via le terminal linux ( qui est mon préféré )

  • La mise à jour manuelle par le téléchargement du code source de Node js.

Pout mettre à jour Nodejs via le terminal linux

Notre solution préférée mais pas obligatoire est l’utilisation du terminale. Pout le résoudre il faut :

  • Nettoyer votre cache npm : npm cache clean -f

  • lancer l’installation de la dernière version stable de node : sudo npm install -g n ( poursuivez même si vous voyez des erreurs. c’est ce que nous avons fait )

  • tapez la command : sudo n stable ( ceci a marché pour nous )

  • vérifier la version de votre node js par la commande : node -v.

Vous pourrez reprendre la création de votre application angular là où ça a échoué. Il se pourrait que le second point ne soit pas nécessaire pour la mise à jour de node mais nous n’avons pas pu faire la vérification pour en être sûr.

Mise à jour manuelle de Node js

La seconde méthode pour les curieux seraient de télécharger le tar.gz de node pour l’installer manuellement. Pour le faire il faut aller sur le site nodejs.org et suivre les instructions posées.

The angular cli requires a minimum node.js version of either

SUR LE MÊME THEME