Android Gradle plugin requires Java 11 to run – dépannage

Dernière mise à jour 3 novembre, 2022 at 10:44

Android Gradle plugin requires Java 11 to run – c’est l’erreur qui s’affiche dans la plus récente version d’android studio . Dans ce post, on vous montre comment on l’a résolu.

 

Ce mois ci je me suis lancé un défi personnel qui est de lire toute la documentation android de google pour mettre à jour mes connaissances en programmation.

L’une des premières choses à faire était d’installer la plus récente version d’android studio ( qui est Dolphin au moment où j’écrit ) et d’appliquer tout ce que j’ai appris sur Jetpack Compose.

L’installation et la création de projet se sont bien passé. Tout avait l’air d’aller jusqu’à ce que je compile le projet . L’ erreur que je li dans le terminal est :

 

Android Gradle plugin requires Java 11 to run

Tournant sur Ubuntu 20.04 lts, je vous montre dans ce post, la méthode que j’ai utilisée pour résoudre le problème.

 

Android Gradle plugin requires Java 11 to run Cliquez pour tweeter

 

Android Gradle plugin requires Java 11 to run – Solutions

 

Si vous lisez la suite du message d’erreurs, l’IDE vous propose déjà 3 solutions pour faire fonctionner votre project.

 

You can try some of the following options:
- changing the IDE settings.
- changing the JAVA_HOME environment variable.
- changing `org.gradle.java.home` in `gradle.properties`.

 

Changez la configuration de l’IDE

 

La toute première solution consiste à indiquer dans la configuration d’android studio que notre projet utilisera java 11 au lieu du jdk par défaut.

Pour le faire , il faut :

 

  • Aller dans Settings

 

  • Dérouler la section Build, Execution, Deployment

 

  • Dans Build Tools , cliquez Gradle

 

  • Dans le formulaire de droite cliquez sur le champ déroulant Gradle JDK et sélectionnez la version du JDK supérieur à java 11.

 

L’image ci dessous vous donne une idée du parcours général.

 

Android Gradle plugin requires Java 11 to run

 

Changez la variable d’environnement JAVA_HOME

 

Cette solution n’a pas fonctionnée pour moi mais peut être, celà sera différente avec vous.

 

Pour changer la variable d’environnement JAVA_HOME il faut suivre les instructions de l’article Configurer JAVA_HOME via commande sous linux.

Le problème que je rencontre avec cette solution est étrange.

Par exemple , le projet peut se mettre à fonctionner si je change le JAVA_HOME dans le terminal d’android studio. Mais il faut refaire l’exercice à chaque fois que je lance l’environnement de développement.

Si j’applique la modification à partir de mon terminal linux hors l’IDE, Le projet ne fonctionnera pas.

Encore une fois, celà peut varier d’un système à un autre mais chez moi, celà n’a pas fonctionné.

 

Modifier le fichier gradle.properties

 

Pour appliquer cette solution il faut aller dans le fichiers gradle.properties puis ajouter la ligne :

org.gradle.java.home=jdk_path

jdk_path est le chemin vers votre jdk.

 

Pour être sûr de le réussir il faut lire parmi les commentaires du fichiers gradle.properties . Vous trouverez peut être le même script en commentaire.

Dans mon cas , quand je l’ai essayé, celà n’avais pas fonctionné. Je ne sais pas pourquoi mais je dois vous avouer que je n’ai pas trop fait mes recherches de ce côté.

Si je l’avais réussi du premier coup, ça allais être de loin ma solution préférée. Mais bon, peut être qu’en trouvant la solution, ça deviendra la vôtre.

 

Abonnez vous à notre newsletter

* indicates required

 

Conclusion

 

J’ai parlé du contexte qui m’a amené vers le problème de compilation du projet android.

L’extrait du message d’erreur en question était Android Gradle plugin requires Java 11 to run .

Dans la suite du message , on trouve déjà 3 propositions de solution pour résoudre le problème de version de votre java. La proposition qui a fonctionné pour moi est la toute première.

Dans ce post j’ai détaillé les étapes à suivre pour résoudre l’erreur avec la première méthode, proposée par gradle.

J’ai  discuté des deux autres solutions proposées en mentionnant les avantages et les inconvéniens que j’ai rencontrés . Bien que séduisantes, il ne faut pas trop espérer que ces solutions marchent du premier coup.

 

Android Gradle plugin requires Java 11 to run

 

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

9 + 13 =