no comments

[ Dépannage ]The Angular CLI requires a minimum Node.js version of either v10.13 or v12.0



Vous êtes en train de créer un projet angular sous un linux de type debian pour la première fois et vous trouvez cet erreur “The Angular CLI requires a minimum Node.js version of either v10.13 or v12.0. “. Que faire ?

Dans ce genre de situation on comprend assez rapidement qu’il suffit de mettre à jour notre node js. Le problème est que parfois on rencontre des imprévus. C’est ce qui nous est arrivé avec notre ubuntu 16.04 LTS et pour le régler, nous vous proposons notre solution.

 

Pout mettre à jour Nodejs via le terminal linux

Notre solution préférée mais pas obligatoire est l’utilisation du terminale. Pout le résoudre il faut :

  • Nettoyer votre cache npm : npm cache clean -f
  • lancer l’installation de la dernière version stable de node : sudo npm install -g n ( poursuivez même si vous voyez des erreurs. c’est ce que nous avons fait )
  • tapez la command : sudo n stable ( ceci a marché pour nous )
  • vérifier la version de votre node js par la commande : node -v.

 

Vous pourrez reprendre la création de votre application angular là où ça a échoué. Il se pourrait que le second point ne soit pas nécessaire pour la mise à jour de node mais nous n’avons pas pu faire la vérification pour en être sûr.

La seconde méthode pour les curieux seraient de télécharger le tar.gz de node pour l’installer manuellement. Pour le faire il faut aller sur le site de nodejs.

 

Conclusion

Vous serez peut être intéressé par [Dépannage] Unity 3d : Deterministic compilation failed. You can disable Deterministic builds in Player Settings et [ Test ]: Powerbank batterie externe Ravpower qui dépasse 20000 mah



Reply

cinq × trois =